Pour désactiver la mise à jour automatique dans WORDPRESS 5.5 vous avez 2 solutions

SOLUTION 1 : au cas par cas

  • Vous pouvez aller dans EXTENSIONS puis cliquer l’option à droite de chaque PLUGIN : vous pouvez alors l’activer ou le désactiver.
  • Cette solution est “fine” : elle est à notre sens adaptée si vous voulez globalement accepter les mises à jour et juste sur quelques modules spécifiques les désactiver.
  • En fonction du thème et des autres modules, l’option de gestion peut ne pas être disponible : dans ce cas, il faut passer à la solution 2

SOLUTION 2 : via le fichier function.php

si vous avez accès à “functions.php” (si vous utilisez un THEME ENFANT et que la notion de ce fichier vous parle), vous n’avez qu’à copier / coller dans ce fichier les lignes de codes suivantes :

// début du copier coller ici
add_filter( 'auto_update_plugin', '__return_false' );
add_filter( 'auto_update_theme', '__return_false' );
add_filter( 'allow_minor_auto_core_updates', '__return_true');
add_filter( 'auto_update_core', '__return_false');
// fin du copier coller ici

Ces lignes disent basiquement : pas d’auto-update sur les plugins (extensions), ni les thèmes, ni la version majeure de WordPress. Mais les faire sur les versions mineures de WordPress

Si vous ne savez pas ce qu’est le fichier function.php, ce n’est pas le moment de faire des essayages : c’est un fichier important de votre thème. Dans ce cas, le plus facile est de télécharger le module ci-après, de l’activer, et de créer un nouveau jeu de règles en rajoutant ces mêmes lignes là-dedans. Si vous avez des questions, n’hésitez pas de nous écrire !

Module code-snippets

Code Snippets

partagez cet article sur...